Multiple Confirmation Emails Being Sent

Incident Report for Lunda Status Page

Monitoring

A fix has been deployed and we are monitoring the results.
Posted May 20, 2026 - 13:12 CEST

Identified

We have identified the cause and are shipping a fix.
Posted May 20, 2026 - 13:02 CEST

Investigating

We are currently investigating an issue which is resulting in multiple confirmation emails being sent for a single donation.
Posted May 14, 2026 - 21:42 CEST
This incident affects: Data & Dashboards (Lunda Administation).